Негізгі мазмұнға өту

Жиі кездесетін мәселелерді жою

Веб-сайттың орнына placeholder беті көрсетіледі​

Бұған бірнеше себеп болуы мүмкін. Ең жиі кездесетіндері:

  • Веб-сайтыңыздың домен атауы үшінші тарап серверіне нұсқап тұр

    Ең алдымен, домен аймағына (DNS) A және AAAA жазбаларын қосу кезінде қате жіберілмегеніне көз жеткізген жөн.

  • Веб-сайттың домен атауы бұл веб-сайт жоқ серверге нұсқап тұр

    Веб-сайтыңыз серверде жасалғанына көз жеткізіңіз. Жаңа бос сайт жасау үшін нұсқаулықты қараңыз.

  • Сіз веб-сайтыңызға HTTPS арқылы кіруге тырысып жатырсыз, бірақ веб-сайтта SSL сертификаты жоқ

    Бұл "Full" шифрлау режимін пайдаланатын Cloudflare қолданушылары арасында жиі кездесетін мәселе. SSL сертификатын пайдалануыңыз керек немесе "Full" режимін өшіріп, веб-сайтқа http:// арқылы кіруіңіз керек.

    Сіз Let's Encrypt қызметінен тегін SSL сертификатын шығара аласыз. Егер сізде SSL сертификаты бұрыннан бар болса, оны серверге қоса аласыз.

  • Веб-сайт домен атауында AAAA жазбасы бар, бірақ веб-сайт баптауларында IPv6 мекенжайы таңдалмаған

    Бұл мәселе тек Интернетке IPv6 арқылы кіретін келушілерге ғана әсер етеді.

    Веб-сайтыңызда IPv6 функциясын қосуыңыз немесе AAAA жазбасын жоюыңыз керек.

    Веб-сайт баптауларын өзгерту үшін FASTPANEL® жүйесіндегі веб-сайт картасына өтіп, содан кейін "Settings" → "Basic" бөліміне өтіңіз. "IP address" ашылмалы тізімінде доменнің AAAA жазбаларында көрсетілген мекенжайларды тексеріңіз.

Басқару панеліне кірген кезде браузерде 404 қатесі​

Егер осы қатеге тап болсаңыз, fastpanel2 бумасының бар-жоғын тексеріңіз, себебі ол басқа бағдарламалық жасақтаманы орнату кезінде тәуелділіктерді шешу үшін ОС бумалар менеджері арқылы жойылған болуы мүмкін.

Debian/Ubuntu үшін:

dpkg -l | grep fastpanel2

CentOS/Alma/Rocky үшін:

rpm -qa | grep fastpanel2

Нәтижеде fastpanel2 деп аталатын бума көрсетілуі керек.

Егер бума шынымен жойылған болса, оны қайта орнатуға болады:

Debian/Ubuntu үшін:

apt install fastpanel2

CentOS/Alma/Rocky үшін:

yum install fastpanel2

fastpanel2 бумасын орнату осы мәселені тудырған бұрын орнатылған бағдарламалық жасақтаманың жойылуына әкелетінін ескеріңіз.

Let's Encrypt SSL сертификатын шығару қатесі DNS кэшіне байланысты емес​

Егер сертификат шығарылып жатқан домен /etc/hosts файлында мынадан басталатын жолдарда болса, сертификатты шығару сәтсіз аяқталуы мүмкін:

127.0.0.1
::1

Сертификатты сәтті шығару үшін /etc/hosts файлындағы осы жолдардан доменді алып тастаңыз.

Жаһандық PHP баптауларына кірген кезде "Unable to execute /path/to/php -f /path/to/file" қатесі пайда болады​

Unable to execute /path/to/php -f /path/to/file қатесі кейбір PHP директиваларын жаһандық деңгейде қайта анықтау кезінде пайда болады.

Бұл мәселені шешу үшін бұл өзгерістерді веб-сайттың PHP баптауларына көшіру ұсынылады. Веб-сайттың PHP баптауларына веб-сайт картасынан қол жеткізуге болады.

ProFTPD қате хабарламасы: "warning: unable to determine IP address of '%hostname'"​

warning: unable to determine IP address of '%hostname' қатесі ProFTPD FTP серверін іске қосу кезінде, егер сервердің hostname-і IP мекенжайға шешілмесе, пайда болады.

Бұл қатені жою үшін сервер үшін жарамды hostname көрсетіңіз. Үшінші деңгейлі доменді пайдалану ұсынылады, мысалы, www.example.com.

Hostname-ді келесі пәрмен арқылы көрсетуге болады:

hostnamectl hostname YOUR_DOMAIN

мұндағы YOUR_DOMAIN — қажетті hostname.

.htaccess сайт ережелері жұмыс істемейді​

Сайттың PHP өңдеушісі PHP-FPM болып орнатылған болуы мүмкін, ал ол .htaccess файлдарының мазмұнын елемейді.

.htaccess файлдары жұмыс істеуі үшін өңдеуші ретінде CGI, FastCGI немесе Apache таңдау қажет.

Веб-сайт журналдарындағы "Fatal error: Allowed memory size of X bytes exhausted (tried to allocate Y bytes)" қатесі​

Қате PHP ішіндегі скрипттердің жадты тұтыну шегінен асып кетуіне байланысты пайда болады.

Әдетте, бұл веб-сайттың PHP баптауларындағы memory_limit параметрін арттыру арқылы шешіледі.

Сонымен қатар, бұл параметрдің мәні .htaccess файлдарында немесе тікелей PHP скрипттерінің өзінде қайта анықталуы мүмкін.

PHP-FPM қызметтері іске қосылмайды​

"Settings" → "Services" мәзіріндегі PHP-FPM қызметтері Stopped күйінде, ал оларды іске қосу әрекеті Unable to start the service. қатесіне әкеледі

PHP-FPM қызметтері автоматты түрде іске қосылады және оларды тек нақты PHP нұсқасы бар қызмет веб-сайтқа қосылған жағдайда ғана басқаруға болады. Егер нақты PHP нұсқасы бар PHP-FPM қызметі ешбір веб-сайтқа қосылмаған болса, оны іске қосу мүмкін емес.

FASTPANEL ішіндегі phpMyAdmin және файл менеджері үшін жүктеу шектеулерін өзгерту​

Файл жүктеу шектеулерін "Settings" → "Main" → "Other" мәзірінде өзгертуге болады.
Maximum file upload size (MB) өрісіне қажетті мәнді енгізіңіз.

521 Cloudflare қатесі - "Web server is down"​

Қызмет бастапқы серверден жауап ала алмағанын хабарлайды. Бұл мәселе келесі себептердің бірімен туындауы мүмкін:

  • Cloudflare DNS баптауларындағы қате IP мекенжай
    Cloudflare DNS баптауларындағы IP мекенжайды тексеріңіз. Егер ол қате болса, оны дұрыс мәнге жаңартыңыз.

  • Nginx веб-сервері жұмыс істемейді
    Серверде Nginx веб-серверінің жұмыс істеп тұрғанын тексеріңіз. Оның күйін тексеру үшін "Settings" → "Services" бөліміне өтіңіз. Егер ол жұмыс істемесе, оны іске қосып көріңіз.

  • Брандмауэр веб-серверге қолжетімділікті бұғаттап тұр
    Веб-сервердің брандмауэр ережелері арқылы бұғатталмағанына көз жеткізіңіз. Серверге SSH арқылы қосылып, келесі пәрмендер арқылы ағымдағы брандмауэр ережелерін тексеріңіз:

    iptables-save
    ip6tables-save

Басқа мәселелер​

Егер осы мақалада FASTPANEL мәселесінің шешімін таппасаңыз, қолдау қызметімізге хабарласыңыз. Сізге көмектесуге қуаныштымыз!