მთავარ შიგთავსზე გადასვლა

გავრცელებული პრობლემების მოგვარება

ვებსაიტის ნაცვლად ნაჩვენებია Placeholder გვერდი​

ამის რამდენიმე მიზეზი შეიძლება არსებობდეს. ყველაზე გავრცელებულია:

  • თქვენი ვებსაიტის დომენის სახელი მიუთითებს მესამე მხარის სერვერზე

    უპირველეს ყოვლისა, ღირს დარწმუნდეთ, რომ დომენის ზონაში (DNS) A და AAAA ჩანაწერების დამატებისას ბეჭდვითი შეცდომები არ დაგიშვიათ.

  • ვებსაიტის დომენის სახელი მიუთითებს სერვერზე, სადაც ეს ვებსაიტი არ არსებობს

    გთხოვთ, დარწმუნდეთ, რომ თქვენი ვებსაიტი შექმნილია სერვერზე. ახალი ცარიელი საიტის შესაქმნელად, გთხოვთ, იხილოთ ინსტრუქცია.

  • თქვენ ცდილობთ თქვენს ვებსაიტზე HTTPS-ით წვდომას, მაგრამ ვებსაიტი არ იყენებს SSL სერტიფიკატს

    ეს გავრცელებული პრობლემაა Cloudflare-ის მომხმარებლებისთვის, რომლებიც იყენებენ "Full" დაშიფვრის რეჟიმს. თქვენ უნდა გამოიყენოთ SSL სერტიფიკატი ან შეხვიდეთ ვებსაიტზე http://-ის საშუალებით გამორთული "Full" რეჟიმით.

    თქვენ შეგიძლიათ გასცეთ უფასო SSL სერტიფიკატი Let's Encrypt-ისგან. თუ უკვე გაქვთ SSL სერტიფიკატი, შეგიძლიათ დაამატოთ ის სერვერზე.

  • ვებსაიტის დომენის სახელს აქვს AAAA ჩანაწერი, მაგრამ IPv6 მისამართი არჩეული არ არის ვებსაიტის პარამეტრებში

    ეს პრობლემა გავლენას მოახდენს მხოლოდ იმ ვიზიტორებზე, რომლებიც ვებზე IPv6-ის საშუალებით შედიან.

    თქვენ უნდა ჩართოთ IPv6 თქვენს ვებსაიტზე ან წაშალოთ AAAA ჩანაწერი.

    ვებსაიტის პარამეტრების შესაცვლელად, გადადით ვებსაიტის ბარათზე FASTPANEL®-ში და შემდეგ "Settings" → "Basic". "IP address" ჩამოსაშლელ სიაში შეამოწმეთ დომენის AAAA ჩანაწერებში მითითებული მისამართები.

ბრაუზერში 404 შეცდომა მართვის პანელზე წვდომისას​

თუ ამ შეცდომას წააწყდებით, შეამოწმეთ fastpanel2 პაკეტის არსებობა, რომელიც შესაძლოა OS-ის პაკეტების მმართველმა წაშალა სხვა პროგრამული უზრუნველყოფის ინსტალაციისას დამოკიდებულებების გადასაჭრელად.

Debian/Ubuntu-სთვის:

dpkg -l | grep fastpanel2

CentOS/Alma/Rocky-სთვის:

rpm -qa | grep fastpanel2

გამოტანილი შედეგი უნდა შეიცავდეს პაკეტს სახელად fastpanel2.

თუ პაკეტი ნამდვილად წაშლილია, შეგიძლიათ ხელახლა დააყენოთ იგი:

Debian/Ubuntu-სთვის:

apt install fastpanel2

CentOS/Alma/Rocky-სთვის:

yum install fastpanel2

გთხოვთ, გაითვალისწინოთ, რომ fastpanel2-ის დაყენება გამოიწვევს ადრე დაყენებული პროგრამული უზრუნველყოფის წაშლას, რომელმაც პრობლემა გამოიწვია.

Let's Encrypt SSL სერტიფიკატის გაცემის შეცდომა, რომელიც DNS ქეშთან არ არის დაკავშირებული​

სერტიფიკატის გაცემა შეიძლება ვერ მოხერხდეს, თუ დომენი, რომლისთვისაც სერტიფიკატი გაიცემა, იმყოფება /etc/hosts ფაილში შემდეგით დაწყებულ ხაზებში:

127.0.0.1
::1

სერტიფიკატის წარმატებით გასაცემად, წაშალეთ დომენი ამ ხაზებიდან /etc/hosts ფაილში.

გლობალურ PHP პარამეტრებზე წვდომისას ჩნდება შეცდომა "Unable to execute /path/to/php -f /path/to/file"​

შეცდომა Unable to execute /path/to/php -f /path/to/file ჩნდება გარკვეული PHP დირექტივების გლობალურად გადაფარვისას.

ამ პრობლემის გადასაჭრელად რეკომენდებულია ამ ცვლილებების გადატანა ვებსაიტის PHP პარამეტრებში. ვებსაიტის PHP პარამეტრებზე წვდომა შესაძლებელია ვებსაიტის ბარათიდან.

ProFTPD შეცდომის შეტყობინება: "warning: unable to determine IP address of '%hostname'"​

შეცდომა warning: unable to determine IP address of '%hostname' ჩნდება ProFTPD FTP სერვერის გაშვებისას, თუ სერვერის hostname ვერ განისაზღვრება IP მისამართად.

ამ შეცდომის მოსაგვარებლად მიუთითეთ სერვერისთვის ვალიდური hostname. რეკომენდებულია მესამე დონის დომენის გამოყენება, მაგალითად, www.example.com.

hostname-ის მითითება შეგიძლიათ შემდეგი ბრძანებით:

hostnamectl hostname YOUR_DOMAIN

სადაც YOUR_DOMAIN სასურველი hostname-ია.

.htaccess საიტის წესები არ მუშაობს​

სავარაუდოდ, საიტის PHP დამმუშავებელი დაყენებულია როგორც PHP-FPM, რომელიც .htaccess ფაილების შიგთავსს უგულებელყოფს.

იმისთვის, რომ .htaccess ფაილებმა იმუშაოს, უნდა აირჩიოთ CGI, FastCGI ან Apache როგორც დამმუშავებელი.

"Fatal error: Allowed memory size of X bytes exhausted (tried to allocate Y bytes)" შეცდომა ვებსაიტის ლოგებში​

ეს შეცდომა წარმოიქმნება იმის გამო, რომ PHP-ში სკრიპტები აჭარბებენ მეხსიერების მოხმარების ლიმიტს.

როგორც წესი, ეს გვარდება ვებსაიტის PHP პარამეტრებში memory_limit პარამეტრის გაზრდით.

დამატებით, ამ პარამეტრის მნიშვნელობა შეიძლება გადაიფაროს .htaccess ფაილებში ან უშუალოდ თავად PHP სკრიპტებში.

PHP-FPM სერვისები არ იშვება​

"Settings" → "Services" მენიუში PHP-FPM სერვისები არის Stopped მდგომარეობაში, და მათი გაშვების მცდელობა იწვევს შეცდომას Unable to start the service.

PHP-FPM სერვისები ავტომატურად იშვება და მათი მართვა შესაძლებელია მხოლოდ იმ შემთხვევაში, თუ კონკრეტული PHP ვერსიის მქონე სერვისი მიერთებულია ვებსაიტთან. თუ კონკრეტული PHP ვერსიის მქონე PHP-FPM სერვისი არც ერთ ვებსაიტთან არ არის მიერთებული, მისი გაშვება შეუძლებელია.

phpMyAdmin-ისა და FASTPANEL-ში ფაილების მმართველის ატვირთვის ლიმიტების შეცვლა​

ფაილების ატვირთვის ლიმიტების შეცვლა შეგიძლიათ მენიუში "Settings" → "Main" → "Other".
შეიყვანეთ სასურველი მნიშვნელობა ველში Maximum file upload size (MB).

521 Cloudflare შეცდომა - "Web server is down"​

სერვისი იუწყება, რომ მან ვერ მიიღო პასუხი წარმოშობის სერვერისგან. ეს პრობლემა შეიძლება გამოწვეული იყოს ერთ-ერთი შემდეგი მიზეზით:

  • Cloudflare DNS პარამეტრებში არასწორი IP მისამართი
    დაადასტურეთ IP მისამართი Cloudflare DNS პარამეტრებში. თუ ის არასწორია, განაახლეთ სწორი მნიშვნელობით.

  • Nginx ვებ სერვერი გაშვებული არ არის
    შეამოწმეთ, გაშვებულია თუ არა Nginx ვებ სერვერი სერვერზე. მისი სტატუსის შესამოწმებლად გადადით "Settings" → "Services". თუ ის გაშვებული არ არის, სცადეთ მისი გაშვება.

  • Firewall ბლოკავს ვებ სერვერზე წვდომას
    დარწმუნდით, რომ ვებ სერვერი არ არის დაბლოკილი firewall-ის წესებით. დაუკავშირდით სერვერს SSH-ით და შეამოწმეთ მიმდინარე firewall-ის წესები ბრძანებებით:

    iptables-save
    ip6tables-save

სხვა პრობლემები​

თუ ამ სტატიაში FASTPANEL-თან დაკავშირებული პრობლემის გადაწყვეტა ვერ იპოვეთ, გთხოვთ, დაუკავშირდეთ ჩვენს მხარდაჭერის სერვისს. სიამოვნებით დაგეხმარებით!